nl.agroconnect.ecrop.defs

Shared types of the AgroConnect eCrop API 1.1.0 (converted from OpenAPI).

Details · defs
Kinddefs
Authorityecrop.agroconnect.nl
Indexed

#additionalProductApplication

object

All relevant the additional product application data per type as part of the PefCR calculation for one crop of one grower in one year

Properties

Type of the applied additional product according to codelist nl.agroconnect.codelist.cl060 (OpenAPI property name: 'type')

Reference

quantity

requiredref

Total quantity of the additional product used for a crop for a year by a grower

Reference

#additionalProductSection

object

All relevant additional product consumption data as part of the PefCR calculation for one crop of one grower in one year

Properties

List of additional product applications per type the footprint is based on.

itemsref

additionalQuestions

requiredarray

Additional questions for PefCR footprint calculation

itemsref

#addressType

object

Generic type for physical addresses

Properties

cityName

requiredstring

City name

Reference

Country name

Postal box number

Postal code of the address

Street name

Street number

Extension to the street number (e.g. an addition letter or suffix)

#allocationDetails

object

Details of the generic class (the parent) for input and output allocation.

Properties

allocationType

requiredref

Indicator for the type of input or output that is used or delivered by this operation. For instance: - "FERTIL" = fertilizer - "PROTEC" = crop protection product - "ENERG" = energy, etc. For this AgroConnect code list nl.agroconnect.codelist.cl271 is used. (OpenAPI property name: 'type')

Reference
itemsref

The greenhouse location the allocation applies to (optional).

name

string

Short name for this allocation.

The plant species the allocation applies to, for instance the species that is planted or sown (optional).

itemsref
Reference

product

requiredref

Product used as allocation in this operation

Reference

quantity

requiredref

Quantity of the allocation measured in absolute terms, meaning for instance applied liters or kilogram in total for this allocation (so not in liter/hectare of kilogram/hectare).

Reference

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the allocation is identified by third parties.

Reference

#assetDetails

object

Details of the entity of a tangible object on which operations can be performed. E.g.: a crop, a building, a machine, a ditch, a greenhouse, a climate control system, a feeding system, etc.

Properties

itemsref

The end data of the existence of the asset.

Reference

name

requiredstring

The start data of the existence of the asset.

Reference

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the asset is identified by third parties

Reference

#characteristicType

object

Generic data type for linked characteristics to a crop, task, operation, allocation, etc.. Exactly one of stringValue, booleanValue, dateValue, dateTimeValue, codeValue, measureValue must be present.

Properties

Boolean value (true/false) of the charateristic

code

requiredref

Content and listId of the code list that contains the coding of characteristics for a specific domain: For instance: The code list id for crop and operations characteristics for arable farming is nl.agrconnect.codelist.cl265.

Reference

Code value and code listid of the characteristic

Reference

Date value of the characteristic

Reference

Date value of the characteristic

Reference

End date of the period this characteristic is or was valid.

Reference

The date the characteristic was captured.

Reference

Numeric value and unit code/listid of the characteristic

Reference

Begin date of the period this characteristic is or was valid.

Reference

String value of the charateristic

#codeType

object

Code Type

Properties

content

requiredstring

Specific code from the code list that is referred to by listId.

listId

requiredref

Identifier as namespace identifier (NSID) expression of the standard code list that contains the allowed codes.

Reference

#componentDetails

object

Specification of one component of the mixed content of a product, for instance a fertilizer.

Properties

code

requiredref

Identification of the component of the composed product. Code list: nl.agroconnect.codelist.cl363

Reference

name

string

Name of the component of the composed product.

quantity

requiredref

Specification of the quantity of this component as part of the composed product. Could be in terms of a percentage or in terms of a dimension; for instance gram/kilogram or milliliter per liter.

Reference

#contractor

object

The contractor who performs tasks and operations on behalf of a grower, for the growers he is granted access to

Properties

E-mail address of the party

iban

string

International Bank Account Number (IBAN) of the party

name

requiredstring

Name of the party

Persons name

Phone number of the party

primaryId

requiredref

(OpenAPI property name: 'id')

Reference

Telefax number of the party

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)

Reference

Address of the website of the party

#contractorDetails

object

The details of the contractor who performs tasks and operations on behalf of a grower

Properties

E-mail address of the party

iban

string

International Bank Account Number (IBAN) of the party

name

requiredstring

Name of the party

Persons name

Phone number of the party

Telefax number of the party

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)

Reference

Address of the website of the party

#countryCodeType

object

Country codes: 2 letter ISO 3166.

Properties

content

requiredstring

Specific code from the code list that is referred to by listId.

listId

requiredref

Identifier as namespace identifier (NSID) expression of the standard code list that contains the allowed codes.

Reference

#crop

object

The cultivation of a specific crop type (e.g. potato, wheat, rice,. etc.) on one or more plots during a specific period of time, specified by startDateTime and endDateTime.

Properties

itemsref

Country where crop is grown. Code list: ISO country code: 2 letter ISO-3166.

Reference

The end data of the existence of the asset.

Reference

Indicates in what type of environment the crop is grown; e.g. in the open air, in a greenhouse, etc. Code list: nl.cl299

Reference

Indicates in what medium the crop is rooted; for instance in soil, in substrate, on bark, etc. Code list: nl.cl300

Reference

name

requiredstring

The net (netto) area (in m2, hectare, etc.) of the surface that is used for growing the crop.

Reference

plantSpecies

requiredarray
itemsref
Reference

plots

array
itemsref
Reference

primaryId

requiredref

(OpenAPI property name: 'id')

Reference

Indicator of the produce purpose the crop. For instance: fresh marked, animal feed, seed production, etc. Code list: nl.cl251

Reference

Indicates the intensity of growing the crop. In The Netherlands used to report to the MLNV-RVO authority. Code list: nl.cl255

Reference

region

string

Region of a country the cultivation took place.\nFor eCrop in The Netherlands for this code list code list nl.cl044 is used.

Production protocol: indicates whether this crop is classified as grown organic or non-organic. Code list: nl.cl015

Reference

The start data of the existence of the asset.

Reference

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the asset is identified by third parties

Reference

Indicates whether the cultivation, over the years, is done in fixed lanes with fixed tracks for machinery.\n\ntrue = track tillage is applied\nfalse = track tillage is not applied

Code to indicate the type of legal ownership of the field that is used for the crop. For eCrop in The Netherlands code list nl.cl412 is used for this

Reference

year

requiredinteger

Indication of the year in which the cultivation is harvested.

#cropDetails

object

The details of the cultivation of a specific crop type (e.g. potato, wheat, rice,. etc.) on one or more plots during a specific period of time, specified by startDateTime and endDateTime.

Properties

itemsref

Country where crop is grown. Code list: ISO country code: 2 letter ISO-3166.

Reference

The end data of the existence of the asset.

Reference

Indicates in what type of environment the crop is grown; e.g. in the open air, in a greenhouse, etc. Code list: nl.cl299

Reference

Indicates in what medium the crop is rooted; for instance in soil, in substrate, on bark, etc. Code list: nl.cl300

Reference

name

requiredstring

The net (netto) area (in m2, hectare, etc.) of the surface that is used for growing the crop.

Reference

plantSpecies

requiredarray
itemsref
Reference

plots

array
itemsref
Reference

Indicator of the produce purpose the crop. For instance: fresh marked, animal feed, seed production, etc. Code list: nl.cl251

Reference

Indicates the intensity of growing the crop. In The Netherlands used to report to the MLNV-RVO authority. Code list: nl.cl255

Reference

region

string

Region of a country the cultivation took place.\nFor eCrop in The Netherlands for this code list code list nl.cl044 is used.

Production protocol: indicates whether this crop is classified as grown organic or non-organic. Code list: nl.cl015

Reference

The start data of the existence of the asset.

Reference

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the asset is identified by third parties

Reference

Indicates whether the cultivation, over the years, is done in fixed lanes with fixed tracks for machinery.\n\ntrue = track tillage is applied\nfalse = track tillage is not applied

Code to indicate the type of legal ownership of the field that is used for the crop. For eCrop in The Netherlands code list nl.cl412 is used for this

Reference

year

requiredinteger

Indication of the year in which the cultivation is harvested.

#cropProtectionApplication

object

All relevant crop protection application data as part of the PefCR calculation for one crop of one grower in one year

Properties

product

requiredref

Details of the applied crop protection product

Reference

quantity

requiredref

Total quantity of the applied crop protection products for a crop for a year by a grower

Reference

substances

requiredarray

List of total quantities of the applied active substances of this product for a crop for a year by a grower

itemsobject

Total quantity of the applied active substance for a crop for a year by a grower

#cropProtectionSection

object

All relevant crop protection data as part of the PefCR calculation for one crop of one grower in one year

Properties

List of applied crop protection products the footprint is based on.

itemsref

#cropSection

object

All relevant crop data as part of the PefCR calculation for one crop of one grower in one year

Properties

additionalQuestions

requiredarray

Additional questions about the crop for PefCR footprint calculation

itemsref

plantSpecies

requiredref

Crop on which the footprint declaration is based.

Reference

#cultivationSection

object

All relevant cultivation (materials) data as part of the PefCR calculation for one crop of one grower in one year

Properties

additionalQuestions

requiredarray

Additional questions about the used cultivation materials for PefCR footprint calculation

itemsref

#dateTimeType

string

Datetime with RFC 9557 (prev. RFC 3339)/ISO-8601 standard (local) datetime format "YYYY-MM-DDThh:mm:ssZ" or "YYYY-MM-DDThh:mm:ss±hh:mm"

#dateType

string

Date with RFC 9557 (prev. RFC 3339)/ISO-8601 standard date format standard date format "YYYY-MM-DD" Format: date. Pattern: ^\d{4}-\d{2}-\d{2}$

#distributionSection

object

All relevant distribution data as part of the PefCR calculation for one crop of one grower in one year

Properties

additionalQuestions

requiredarray

Additional questions about distribution for PefCR footprint calculation

itemsref

#energyProductionAndConsumption

object

All relevant the energy production and consumption data per type as part of the PefCR calculation for one crop of one grower in one year

Properties

energyType

requiredref

Type of the produced and consumed energy. Codelist id cl902 (OpenAPI property name: 'type')

Reference

quantity

requiredref

Total quantity of the type of produced and consumed energy for a crop for a year by a grower

Reference

#energySection

object

All relevant energy production and consumption as part of the PefCR calculation for one crop of one grower in one year

Properties

additionalQuestions

requiredarray

Additional questions on energy production and consumption for PefCR footprint calculation

itemsref

List of energy production and consumption per type the footprint is based on.

itemsref

#equipmentAssignment

object

Identifies a piece of equipment that is used in a certain operation, and the period and usage figures of that use.

Properties

The total distance covered by the equipment during the operation.

Reference

The date/timestamp the equipment stopped being used in the operation.

Reference

equipment

requiredref

The equipment assigned to and used in the operation.

Reference

The total time the equipment was in use during the operation (e.g. working hours or engine hours).

Reference

The date/timestamp the equipment started being used in the operation.

Reference

#equipmentDetails

object

Details of equipment used to support farming activities, such as tractors, implements, sensor systems, installations, or hand tools.

Properties

Type of equipment, for instance Tractor, ImplementAssembly, SensorSystem, Installation or HandTool. Code list: nl.agroconnect.codelist.cl962 (OpenAPI property name: 'type')

Reference

name

requiredstring

Name of the equipment

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the equipment is identified by third parties, e.g. GS1 GTIN, CGTB authorisation number, article code'

Reference

#fertilizerApplication

object

All relevant synthetic fertilizer data as part of the PefCR calculation for one crop of one grower in one year

Properties

fertilizerType

requiredref

Type of the applied fertilizer product (OpenAPI property name: 'type')

Reference

List of total quantities of the applied nutrients of this product for a crop for a year by a grower

itemsobject

Total quantity of the applied nutrient for a crop for a year by a grower

product

requiredref

Information of the applied fertilizer product

Reference

quantity

requiredref

Total quantity of the applied fertilizer for a crop for a year by a grower

Reference

#fertilizerSection

object

All relevant fertilizer data as part of the PefCR calculation for one crop of one grower in one year

Properties

additionalQuestions

requiredarray

Additional questions on fertilizer application for PefCR footprint calculation

itemsref

List of (synthetic and organic) fertilizers the footprint is based on.

itemsref

#footprintDeclaration

object

All relevant data for PefCR calculation for one crop at one production location of one grower in one period

Properties

cropSection

requiredref
Reference

declarationId

requiredref

Identification of the footprint declaration as assigned by the data provider. (OpenAPI property name: 'id')

Reference

endDate

requiredref

End date of the period the footprint declaration applies to

Reference

energySection

requiredref
Reference
Reference

grower

requiredref

The grower who is owner of the crop the footprint is calculated on

Reference

locationSection

requiredref
Reference

sequenceNumber

requiredref

Sequence number of the footprint declaration. Grower-identification, year and sequence number uniquely identify a footprint declaration (which can have multiple versions).

Reference

startDate

requiredref

Start date of the period the footprint declaration applies to

Reference

Third party identifications of the footprint declaration.

Reference

Date-time of publication of the footprint declaration.

Reference

versionNumber

requiredref

Version number of the footprint declaration. A footprint declaration, identified by grower, year and sequence number, can have multiple versions; the highest version number is the most recent.

Reference

wasteSection

requiredref
Reference

#greenhouseLocationDetails

object

Structure with transparent walls and roof designed to regulate temperature and humidity for growing plants.

Properties

blockId

string

Identifier of a block (in Dutch: afdeling) within the greenhouse.

Coordinates of the standard Hortivation location reference point for the block

name

requiredstring

Name of the greenhouse

postId

string

Identifier of a post (in Dutch: paal) within the block of the greenhouse

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the greenhouse is identified by third parties

Reference

Identifier of a second post (in Dutch: paal) within the block of the greenhouse. The upToPost can be used to refer to the location between two posts (postId and upToPostId).

Identifier of a watertap (in Dutch: waterpunt) within a greenhouse.

The xyz-position to the standard Hortivationpoint of this block within a greenhouse

#grower

object

The grower (e.g. the farmer) that is responsible for the cultivation of the crop.

Properties

E-mail address of the party

iban

string

International Bank Account Number (IBAN) of the party

name

requiredstring

Name of the party

Persons name

Phone number of the party

primaryId

requiredref

(OpenAPI property name: 'id')

Reference

Telefax number of the party

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)

Reference

Address of the website of the party

#growerDetails

object

The details of the grower (e.g. the farmer) that is responsible for the cultivation of the crop.

Properties

E-mail address of the party

iban

string

International Bank Account Number (IBAN) of the party

name

requiredstring

Name of the party

Persons name

Phone number of the party

Telefax number of the party

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)

Reference

Address of the website of the party

#health

object

Health Check Response Format for HTTP APIs

Properties

status

requiredstring

Indicates whether the service status is acceptable or not

  • knownValues: pass | warn | fail

#idType

object

Generice IdType with which a resource is identified

Properties

content

requiredstring

Identifier value.

  • minLength: 1

schemeId

requiredstring

Scheme Id of the identifier.

  • minLength: 1

#inboundDeliveryByGrower

object

Materials and inputs delivered by a supplier to a grower as input for their crop process. An inbound delivery describes a certain amount of a certain product acquired by a grower through an order to a supplier.

Properties

dateOfDelivery

requiredref

Date at which the product is delivered at the location of the grower ("YYYY-MM-DD")

Reference

location

requiredref

Identification of the production location of the grower at which the product is delivered

primaryId

requiredref

(OpenAPI property name: 'id')

Reference

product

requiredref
Reference

quantity

requiredref

Quantity of the product delivered to the grower.

Reference

supplier

requiredref
Reference

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the inbound delivery is identified by third parties.

Reference

#inboundDeliveryBySupplier

object

Materials and inputs delivered by a supplier to a grower as input for their crop process. An inbound delivery describes a certain amount of a certain product acquired by a grower through an order to a supplier.

Properties

dateOfDelivery

requiredref

Date at which the product is delivered at the location of the grower ("YYYY-MM-DD")

Reference

location

requiredref

Identification of the production location of the grower at which the product is delivered

primaryId

requiredref

(OpenAPI property name: 'id')

Reference

product

requiredref
Reference

quantity

requiredref

Quantity of the product delivered to the grower.

Reference

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the inbound delivery is identified by third parties.

Reference

#inboundDeliveryDetails

object

Details of materials and inputs delivered by a supplier to a grower as input for their crop process. An inbound delivery describes a certain amount of a certain product acquired by a grower through an order to a supplier.

Properties

dateOfDelivery

requiredref

Date at which the product is delivered at the location of the grower ("YYYY-MM-DD")

Reference

location

requiredref

Identification of the production location of the grower at which the product is delivered

product

requiredref
Reference

quantity

requiredref

Quantity of the product delivered to the grower.

Reference

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the inbound delivery is identified by third parties.

Reference

#inboundDeliveryDetailsByGrower

object

Details of the materials and inputs delivered by a supplier to a grower as input for their crop process. An inbound delivery describes a certain amount of a certain product acquired by a grower through an order to a supplier.

Properties

dateOfDelivery

requiredref

Date at which the product is delivered at the location of the grower ("YYYY-MM-DD")

Reference

location

requiredref

Identification of the production location of the grower at which the product is delivered

product

requiredref
Reference

quantity

requiredref

Quantity of the product delivered to the grower.

Reference

supplier

requiredref
Reference

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the inbound delivery is identified by third parties.

Reference

#inputAllocationDetails

object

One or more inputs used to execute this operation. Examples of types of input are: crop protection products, fertilizer, water, energy, labor, etc.

Properties

allocationType

requiredref

Indicator for the type of input or output that is used or delivered by this operation. For instance: - "FERTIL" = fertilizer - "PROTEC" = crop protection product - "ENERG" = energy, etc. For this AgroConnect code list nl.agroconnect.codelist.cl271 is used. (OpenAPI property name: 'type')

Reference
itemsref

Specification of the mixed content (mixture of several components) of the input, for instance a fertilizer.

itemsref
Reference

The greenhouse location the allocation applies to (optional).

name

string

Short name for this allocation.

The plant species the allocation applies to, for instance the species that is planted or sown (optional).

itemsref
Reference

product

requiredref

Product used as allocation in this operation

Reference

quantity

requiredref

Quantity of the allocation measured in absolute terms, meaning for instance applied liters or kilogram in total for this allocation (so not in liter/hectare of kilogram/hectare).

Reference

reason

string

Short description of the reason why this particular input (e.g. this crop protection product) is used.

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the allocation is identified by third parties.

Reference

treatmentzone

requiredref

#jsonPatch

array

Request payload for PATCH operations: a JSON Patch document as defined in ["JavaScript Object Notation (JSON) Patch", RFC 6902](https://datatracker.ietf.org/doc/html/rfc6902), per AASG rule P012. Use media type `application/json-patch+json`. The document is an array of operation objects, applied sequentially in the order given. If any operation fails, the whole patch document MUST NOT be applied (RFC 6902, section 5).

  • minLength: 1

Items

itemsref

#jsonPatchOperation

object

One RFC 6902 JSON Patch operation. 'value' is required for add, replace and test; 'from' is required for move and copy.

Properties

from

string

op

requiredstring
  • knownValues: add | remove | replace | move | copy | test

path

requiredstring

value

unknown

#locationSection

object

All relevant location data as part of the PefCR calculation for one crop of one grower in one year

Properties

additionalQuestions

requiredarray

Additional questions about the location for PefCR footprint calculation

itemsref

location

requiredref

Identification of the production location of the grower at which the crop is grown

#measureType

object

Standard data type for expressing a measurement with a value and unitcode. To be used for all types of measurements and quantities in this class model.

Properties

content

requiredinteger

Expresses the measured value of the measurement. Integer mantissa, scaled by scaleFactor (originally a float).

scaleFactor

requiredinteger

Power of 10 exponent to apply to the integer value(s) of this object: realValue = value * 10^scaleFactor. E.g. value 125 with scaleFactor -2 is 1.25.

unitCode

requiredref

The code that refers to the standard unit or dimension to express the value of this measurement. E.g. kg for kilogram. listId: nl.agroconnect.codelist.cl020

Reference

#nsidType

string

Namespace Identifier (NSID) Type used in the AT Protocol for decentralized identities, structured using reverse domain name syntax Pattern: ^[a-zA-Z]([a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?(\.[a-zA-Z0-9]([a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?)+(\.[a-zA-Z]([a-zA-Z0-9]{0,62})?)$

#nutrientDetails

object

Details of an nutrient used in a fertilizer product.

Properties

List of additional nutrient characteristics

itemsref

name

string

Name of the nutrient

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the nutrient is identified by third parties

Reference

#operationDetails

object

Activity carried out by man and/or machine as part op the execution of a task. An operation performs a particular OperationTechnique on a particular asset (a crop,a field, a production unit, a batch, etc.) to realize a certain Cultural Practice or Husbandry Practice. Examples for CropProduction: The CulturalPractise "weed control"can be realized by one of various OperationTechniques like spraying, row cultivation, manual hoeing, etc.

Properties

area

ref

The treated area (hectare, m2) during the execution of this operation. Can be a percentage of the total area or an absolute value (like hectare or square meter).

Reference

The option to attach one or more characteristics about the execution of this operation.

itemsref

The date/timestamp of the ending of execution the operation.

Reference

The option to attach one or more pieces of equipment used to execute this operation.

itemsref

The option to attach one or more inputs used to execute this operation, such as crop protection products, fertilizer, water, energy, or labor.

itemsref

name

requiredstring

Short name of the operation.

note

string

Optional free-text note about the operation.

operationType

requiredref

The type of operation. Code list Id for arable farming: nl.agroconnect.cl127 (OpenAPI property name: 'type')

Reference

The option to attach one or more outputs resulting from the execution of this operation, such as harvested produce or energy.

itemsref

startDateTime

requiredref

The date/timestamp of beginning the execution of the operation.

Reference

status

requiredref
Reference

Examples for Crop Production: The CulturalPractise \"weed control\" can be realized by one of various OperationTechniques like spraying, row cultivation, manual hoeing, etc. \r\nCode list Id for arable farming: nl.cl127 (or nl.cl293)

Reference

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the operation is identified by third parties.

Reference

The option to attach one or more workers assigned to execute this operation.

itemsref
Reference

#outputAllocationDetails

object

One or more outputs as the result of the execution of the operation. For example harvested produce: potatoes, onions, flowers, vegetables, etc. But an output could also be for instance energy.

Properties

allocationType

requiredref

Indicator for the type of input or output that is used or delivered by this operation. For instance: - "FERTIL" = fertilizer - "PROTEC" = crop protection product - "ENERG" = energy, etc. For this AgroConnect code list nl.agroconnect.codelist.cl271 is used. (OpenAPI property name: 'type')

Reference
itemsref

The greenhouse location the allocation applies to (optional).

name

string

Short name for this allocation.

The plant species the allocation applies to, for instance the species that is planted or sown (optional).

itemsref
Reference

product

requiredref

Product used as allocation in this operation

Reference

quantity

requiredref

Quantity of the allocation measured in absolute terms, meaning for instance applied liters or kilogram in total for this allocation (so not in liter/hectare of kilogram/hectare).

Reference

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the allocation is identified by third parties.

Reference

treatmentzone

requiredref

#partyDetails

object

Data about the Party that is involved in producing or processing the crop and or agricultural produce.

Properties

E-mail address of the party

iban

string

International Bank Account Number (IBAN) of the party

name

requiredstring

Name of the party

Persons name

Phone number of the party

Telefax number of the party

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)

Reference

Address of the website of the party

#plantSpecies

object

Crop type at the level of potato, sugar beet, onion, winter wheat, etc. For mixed crops more then one type of crop can be grown in the same period at the same plot.

Properties

To be used in case of a mixed crop. Indicator of the percentage of this crop species related to the other crop species that are part of this mixed crop. The percentage is based on the weight proportions of the seed of each of the species that are part of the mixed crop. Integer mantissa, scaled by scaleFactor (originally a float).

Power of 10 exponent to apply to the integer value(s) of this object: realValue = value * 10^scaleFactor. E.g. value 125 with scaleFactor -2 is 1.25.

  • default: 0

species

requiredref

Code of the plant species, at the aggregation level of potato, sugar beet, onion, etc. For eCrop in The Netherlands, code list nl.cl263 is used for crop species.

Reference

Identification of the variety of the type of crop that is grown. For eCrop in The Netherlands code list nl.cl232 is used.

Reference

#plot

object

Surface (area) that is used to grow plants. The exact location of this surface is specified by either, a greenhouse-location a point location or a border location (using outer and inner polygons). The geo-information of a plot is published via the plot-geometry operations. A plot does not store the id of its feature(s): the link with rel `https://ecrop.agroconnect.nl/rel/plot-features` in the `links` of a Plot response is a query for the features that refer to this plot (a "backlink"), see GET /collections/plots/items.

Properties

Option to include a second, alternative, name for the plot. For instance to be used to include the name the farmer registered in his FMIS and the name that is registered in the RVO-database.

area

requiredref

The surface (measured in for instance square meters, hectare) of this production plot.

Reference
itemsref

The country the plot is located in.

Reference

The end data of the existence of the asset.

Reference

The land use category of this plot. Code list: nl.agroconnect.codelist.cl961. Possible values: ARL (Arable Land), GRL (Grassland), FLL (Fallow Land) and NTA (Natural Area).

Reference

Code for the soil type, as used for a specific use case. LocalSoilType code consists of the reference to the code list that is being used plus the code from this code list. For eCrop in arable farming in The Netherlands, code list nl.cl405 is used

Reference

name

requiredstring

plotType

requiredref

(OpenAPI property name: 'type')

Reference

primaryId

requiredref

(OpenAPI property name: 'id')

Reference

region

string

The region the plot is located in.

Indicates whether this plot is classified for organic production or not. Production protocol: indicates whether this plot is classified for organic production or not. Code list: nl.cl015

Reference

Code for the soil type, as subscribed by a regulatory authority (e.g. MLNV-RVO in the Netherlands). For eCrop in The Netherlands code list nl.cl405 is used.

Reference

The start data of the existence of the asset.

Reference

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the asset is identified by third parties

Reference

#plotDetails

object

Details of the Surface (area) that is used to grow plants. The exact location of this surface is specified by either, a greenhouse-location a point location or a border location (using outer and inner polygons).

Properties

Option to include a second, alternative, name for the plot. For instance to be used to include the name the farmer registered in his FMIS and the name that is registered in the RVO-database.

area

requiredref

The surface (measured in for instance square meters, hectare) of this production plot.

Reference
itemsref

The country the plot is located in.

Reference

The end data of the existence of the asset.

Reference

The land use category of this plot. Code list: nl.agroconnect.codelist.cl961. Possible values: ARL (Arable Land), GRL (Grassland), FLL (Fallow Land) and NTA (Natural Area).

Reference

Code for the soil type, as used for a specific use case. LocalSoilType code consists of the reference to the code list that is being used plus the code from this code list. For eCrop in arable farming in The Netherlands, code list nl.cl405 is used

Reference

name

requiredstring

plotType

requiredref

(OpenAPI property name: 'type')

Reference

region

string

The region the plot is located in.

Indicates whether this plot is classified for organic production or not. Production protocol: indicates whether this plot is classified for organic production or not. Code list: nl.cl015

Reference

Code for the soil type, as subscribed by a regulatory authority (e.g. MLNV-RVO in the Netherlands). For eCrop in The Netherlands code list nl.cl405 is used.

Reference

The start data of the existence of the asset.

Reference

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the asset is identified by third parties

Reference

#plotType

string

The type of production surface to grow plants. Can be a crop field for arable farming or a moving table (platform) for potted plants in floriculture.

  • knownValues: CROPFIELD | ACTIVITYFIELD | TABLE

#posInt32Type

integer
  • minimum: 0

#posInt64Type

integer
  • minimum: 0

#postalAddressType

object

Specific ype for postal addresses

Properties

cityName

requiredstring

City name

Reference

Country name

Postal box number

Postal code of the address

Street name

Street number

Extension to the street number (e.g. an addition letter or suffix)

#primaryId

object

Primary identification for the resources as assigned by the server

Properties

primaryId

requiredref

(OpenAPI property name: 'id')

Reference

#primaryIdContentType

string

The type for the content-part of primary ids of resources Format: uuid.

#primaryIdSchemeIdType

string

The type for the schemeId part of primary ids of resources

#primaryIdType

object

Primary identification for the resources as assigned by the server

Properties

content

requiredref

schemeId

requiredref

#problemDetails

object

Problem details based on the ["Problem Details for HTTP APIs" specification, RFC 9457](https://datatracker.ietf.org/doc/html/rfc9457). Remark: According to Proposal NL API Design Rules 2.1 optional properties status, title and detail are required, type and instance are optional

Properties

detail

requiredstring

A human-readable explanation specific to this occurrence of the problem.

errors

array

List of individual validation errors, allowing multiple issues encountered while processing the request to be reported together in a single response (per AASG rule H007). This is an AASG-specific extension member of RFC 9457 Problem Details, not part of the base RFC itself.

itemsobject

instance

string

A URI reference that identifies the specific occurrence of the problem. It may or may not yield further information if dereferenced. Format: uri-reference.

A URI reference that identifies the problem type. Format: uri-reference. (OpenAPI property name: 'type')

status

requiredinteger

The HTTP status code generated by the origin server for this occurrence of the problem.

  • minimum: 100
  • maximum: 599

title

requiredstring

A short, human-readable summary of the problem type.

#processStateType

string

Indication of the execution status of the task or operation in terms of: proposed, planned, executed. Code list: nl.clL256

  • knownValues: PROPOSED | PLANNED | COMPLETED

#productDetails

object

Details of a product delivered to a farmer, like any agricultural input, tool, or resource designed to support farming activities, such as seeds, fertilizers, animal feed or crop protection solutions.

Properties

List of additional product characteristics

itemsref

name

string

Name of the product

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the product is identified by third parties, e.g. GS1 GTIN, CGTB authorisation number, article code'

Reference

#productionLocation

object

The the entity that is responsible for cultivation the crops.

Properties

E-mail address of the party

iban

string

International Bank Account Number (IBAN) of the party

name

requiredstring

Name of the party

Persons name

Phone number of the party

primaryId

requiredref

(OpenAPI property name: 'id')

Reference

Telefax number of the party

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)

Reference

Address of the website of the party

#productionLocationDetails

object

The details of the entity that is responsible for cultivation the crops.

Properties

E-mail address of the party

iban

string

International Bank Account Number (IBAN) of the party

name

requiredstring

Name of the party

Persons name

Phone number of the party

Telefax number of the party

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)

Reference

Address of the website of the party

#productionSequenceType

string

Indicates if and how the crop is combined with other crops. Enumeration: PRE_CROP = voorteelt, MAIN_CROP = hoofdteelt, FOLLOWUP_CROP = volgteelt, MIXED_CROP = mengteelt

  • knownValues: PRE_CROP | MAIN_CROP | FOLLOWUP_CROP | MIXED_CROP

#substanceDetails

object

Details of an active substance used in a crop protection product.

Properties

List of additional substance characteristics

itemsref

name

string

Name of the substance

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the substance is identified by third parties, e.g. CAS (Chemical Abstracts Service) number, EC (European Community) number '

Reference

#supplier

object

The supplier who delivers goods to a grower

Properties

E-mail address of the party

iban

string

International Bank Account Number (IBAN) of the party

name

requiredstring

Name of the party

Persons name

Phone number of the party

primaryId

requiredref

(OpenAPI property name: 'id')

Reference

Telefax number of the party

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)

Reference

Address of the website of the party

#supplierDetails

object

The details of the supplier who delivers goods to a grower

Properties

E-mail address of the party

iban

string

International Bank Account Number (IBAN) of the party

name

requiredstring

Name of the party

Persons name

Phone number of the party

Telefax number of the party

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)

Reference

Address of the website of the party

#task

object

A Task is the execution of one or more Operation's by a ma-machine-system. A 'task' consists of one ore more 'operations' that are closely related but involve different assents and resources. All combined operations need to be carried out well coordinated, to execute the task. For instance, the task potato harvesting involves: one tractor pulling the potato harvester, 2 units to take care of the transport of the harvested potatoes to the barn, equipment at the barn to unload the transport units and to bring the produce in the storing place.

Properties

The date/timestamp of the ending of execution the task.

Reference

name

requiredstring

Short name of the task.

note

string

Optional free-text note about the task.

operations

requiredarray
itemsref
Reference

primaryId

requiredref

(OpenAPI property name: 'id')

Reference

startDateTime

requiredref

The date/timestamp of beginning the execution of the task.

Reference

status

requiredref
Reference

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the task is identified by third parties.

Reference

#taskDetails

object

A Task is the execution of one or more Operation's by a ma-machine-system. A 'task' consists of one ore more 'operations' that are closely related but involve different assents and resources. All combined operations need to be carried out well coordinated, to execute the task. For instance, the task potato harvesting involves: one tractor pulling the potato harvester, 2 units to take care of the transport of the harvested potatoes to the barn, equipment at the barn to unload the transport units and to bring the produce in the storing place.

Properties

The date/timestamp of the ending of execution the task.

Reference

name

requiredstring

Short name of the task.

note

string

Optional free-text note about the task.

operations

requiredarray
itemsref
Reference

startDateTime

requiredref

The date/timestamp of beginning the execution of the task.

Reference

status

requiredref
Reference

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the task is identified by third parties.

Reference

#thirdPartyIdsType

array

List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties

Items

itemsref
Reference

#timeLocalType

string

Time with RFC 9557 (prev. RFC 3339) partial-time format "hh:mm:ss" Format: time-local. Pattern: ^(\d{2}):(\d{2}):(\d{2})$

#timeType

string

Time with RFC 9557 (prev. RFC 3339) full-time format "hh:mm:ss+/-hh:mm" Format: time. Pattern: ^(\d{2}):(\d{2}):(\d{2})(\.\d+)?(Z|[+-]\d{2}:\d{2})$

#treatmentZoneDetails

object

Part of the plot which is treated in an operation

Properties

area

ref
Reference
itemsref

Specification of the end of the treatment zone. For instance an identifier of a bed of Tulips in an open field.

Specification of the beginning of the treatment zone. For instance an identifier of a bed of Tulips in an open field.

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the treatment zone is identified by third parties.

Reference

#visitorsAddressType

object

Specific ype for visitor addresses

Properties

cityName

requiredstring

City name

Reference

Country name

Postal box number

Postal code of the address

Street name

Street number

Extension to the street number (e.g. an addition letter or suffix)

#wasteSection

object

All relevant waste data as part of the PefCR calculation for one crop of one grower in one year

Properties

additionalQuestions

requiredarray

Additional questions about waste for PefCR footprint calculation

itemsref

#waterConsumption

object

All relevant the water consumption data per type as part of the PefCR calculation for one crop of one grower in one year

Properties

quantity

requiredref

Total quantity of the type of water used for a crop for a year by a grower

Reference

Type of the applied water according to codelist nl.agroconnect.codelist.cl060 (OpenAPI property name: 'type')

Reference

#waterConsumptionSection

object

All relevant water consumption data as part of the PefCR calculation for one crop of one grower in one year

Properties

additionalQuestions

requiredarray

Additional questions on water consumption for PefCR footprint calculation

itemsref

waterConsumptions

requiredarray

List of water consumptions per type the footprint is based on.

itemsref
Reference

#workerAssignment

object

Identifies a worker that is assigned to a certain operation, and the period and execution time of that assignment.

Properties

The date/timestamp the worker stopped working on the operation.

Reference

The total time the worker spent executing the operation.

Reference

The date/timestamp the worker started working on the operation.

Reference

worker

requiredref

The worker assigned to the operation.

Reference

#workerDetails

object

Details of a person that performs (part of) an operation, e.g. a farm employee or contractor.

Properties

eMail

string

E-mail address of the worker.

jobTitle

string

Job title of the worker.

name

requiredstring

Name of the worker.

Phone number of the worker.

thirdPartyIds

requiredref

List of alternative identifiers (\"AKA, also-know-as\") with which the worker is identified by third parties, e.g. an employee number

Reference

#yearType

string

Year with RFC 9557 (prev. RFC 3339)/ISO-8601 standard date format "YYYY" Pattern: ^\d{4}$

Similar lexicons

semantic match

Lexicons whose schemas describe something close to this one. Check them before publishing a new one that overlaps.

  • All relevant data for PefCR calculation for one crop at one production location of one grower in one period

  • Details of the Surface (area) that is used to grow plants. The exact location of this surface is specified by either, a greenhouse-location a point location or a border location (using outer and inner polygons).

  • The details of the cultivation of a specific crop type (e.g. potato, wheat, rice,. etc.) on one or more plots during a specific period of time, specified by startDateTime and endDateTime.

  • The details of the entity that is responsible for cultivation the crops.

  • The details of the grower (e.g. the farmer) that is responsible for the cultivation of the crop.