(OpenAPI property name: 'id')
nl.agroconnect.ecrop.defs
Shared types of the AgroConnect eCrop API 1.1.0 (converted from OpenAPI).
Details · defs
| Kind | defs |
|---|---|
| Authority | ecrop.agroconnect.nl |
| Indexed |
#additionalProductApplication
objectAll relevant the additional product application data per type as part of the PefCR calculation for one crop of one grower in one year
Properties
Type of the applied additional product according to codelist nl.agroconnect.codelist.cl060 (OpenAPI property name: 'type')
Total quantity of the additional product used for a crop for a year by a grower
#additionalProductSection
objectAll relevant additional product consumption data as part of the PefCR calculation for one crop of one grower in one year
Properties
List of additional product applications per type the footprint is based on.
Additional questions for PefCR footprint calculation
#addressType
objectGeneric type for physical addresses
Properties
City name
country
refcountryName
stringCountry name
postalBoxId
stringPostal box number
postalCode
stringPostal code of the address
streetName
stringStreet name
streetNumber
stringStreet number
streetNumberExtension
stringExtension to the street number (e.g. an addition letter or suffix)
#allocationDetails
objectDetails of the generic class (the parent) for input and output allocation.
Properties
Indicator for the type of input or output that is used or delivered by this operation. For instance: - "FERTIL" = fertilizer - "PROTEC" = crop protection product - "ENERG" = energy, etc. For this AgroConnect code list nl.agroconnect.codelist.cl271 is used. (OpenAPI property name: 'type')
characteristics
arrayThe greenhouse location the allocation applies to (optional).
name
stringShort name for this allocation.
plantSpecies
arrayThe plant species the allocation applies to, for instance the species that is planted or sown (optional).
Product used as allocation in this operation
Quantity of the allocation measured in absolute terms, meaning for instance applied liters or kilogram in total for this allocation (so not in liter/hectare of kilogram/hectare).
List of alternative identifiers (\"AKA, also-know-as\") with which the allocation is identified by third parties.
#assetDetails
objectDetails of the entity of a tangible object on which operations can be performed. E.g.: a crop, a building, a machine, a ditch, a greenhouse, a climate control system, a feeding system, etc.
Properties
characteristics
arrayList of alternative identifiers (\"AKA, also-know-as\") with which the asset is identified by third parties
#characteristicType
objectGeneric data type for linked characteristics to a crop, task, operation, allocation, etc.. Exactly one of stringValue, booleanValue, dateValue, dateTimeValue, codeValue, measureValue must be present.
Properties
booleanValue
booleanBoolean value (true/false) of the charateristic
Content and listId of the code list that contains the coding of characteristics for a specific domain: For instance: The code list id for crop and operations characteristics for arable farming is nl.agrconnect.codelist.cl265.
Date value of the characteristic
measureValue
refNumeric value and unit code/listid of the characteristic
stringValue
stringString value of the charateristic
#codeType
objectCode Type
#componentDetails
objectSpecification of one component of the mixed content of a product, for instance a fertilizer.
Properties
Identification of the component of the composed product. Code list: nl.agroconnect.codelist.cl363
name
stringName of the component of the composed product.
Specification of the quantity of this component as part of the composed product. Could be in terms of a percentage or in terms of a dimension; for instance gram/kilogram or milliliter per liter.
#contractor
objectThe contractor who performs tasks and operations on behalf of a grower, for the growers he is granted access to
Properties
emailAddress
stringE-mail address of the party
iban
stringInternational Bank Account Number (IBAN) of the party
Name of the party
personName
stringPersons name
phoneNumber
stringPhone number of the party
(OpenAPI property name: 'id')
telefaxNumber
stringTelefax number of the party
List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)
websiteUrl
stringAddress of the website of the party
#contractorDetails
objectThe details of the contractor who performs tasks and operations on behalf of a grower
Properties
emailAddress
stringE-mail address of the party
iban
stringInternational Bank Account Number (IBAN) of the party
Name of the party
personName
stringPersons name
phoneNumber
stringPhone number of the party
telefaxNumber
stringTelefax number of the party
List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)
websiteUrl
stringAddress of the website of the party
#countryCodeType
objectCountry codes: 2 letter ISO 3166.
#crop
objectThe cultivation of a specific crop type (e.g. potato, wheat, rice,. etc.) on one or more plots during a specific period of time, specified by startDateTime and endDateTime.
Properties
characteristics
arraycountry
refCountry where crop is grown. Code list: ISO country code: 2 letter ISO-3166.
Indicates in what type of environment the crop is grown; e.g. in the open air, in a greenhouse, etc. Code list: nl.cl299
growMedium
refIndicates in what medium the crop is rooted; for instance in soil, in substrate, on bark, etc. Code list: nl.cl300
netArea
refThe net (netto) area (in m2, hectare, etc.) of the surface that is used for growing the crop.
(OpenAPI property name: 'id')
Indicator of the produce purpose the crop. For instance: fresh marked, animal feed, seed production, etc. Code list: nl.cl251
Indicates the intensity of growing the crop. In The Netherlands used to report to the MLNV-RVO authority. Code list: nl.cl255
region
stringRegion of a country the cultivation took place.\nFor eCrop in The Netherlands for this code list code list nl.cl044 is used.
Production protocol: indicates whether this crop is classified as grown organic or non-organic. Code list: nl.cl015
List of alternative identifiers (\"AKA, also-know-as\") with which the asset is identified by third parties
trackTillage
booleanIndicates whether the cultivation, over the years, is done in fixed lanes with fixed tracks for machinery.\n\ntrue = track tillage is applied\nfalse = track tillage is not applied
useTitle
refCode to indicate the type of legal ownership of the field that is used for the crop. For eCrop in The Netherlands code list nl.cl412 is used for this
Indication of the year in which the cultivation is harvested.
#cropDetails
objectThe details of the cultivation of a specific crop type (e.g. potato, wheat, rice,. etc.) on one or more plots during a specific period of time, specified by startDateTime and endDateTime.
Properties
characteristics
arraycountry
refCountry where crop is grown. Code list: ISO country code: 2 letter ISO-3166.
Indicates in what type of environment the crop is grown; e.g. in the open air, in a greenhouse, etc. Code list: nl.cl299
growMedium
refIndicates in what medium the crop is rooted; for instance in soil, in substrate, on bark, etc. Code list: nl.cl300
netArea
refThe net (netto) area (in m2, hectare, etc.) of the surface that is used for growing the crop.
Indicator of the produce purpose the crop. For instance: fresh marked, animal feed, seed production, etc. Code list: nl.cl251
Indicates the intensity of growing the crop. In The Netherlands used to report to the MLNV-RVO authority. Code list: nl.cl255
region
stringRegion of a country the cultivation took place.\nFor eCrop in The Netherlands for this code list code list nl.cl044 is used.
Production protocol: indicates whether this crop is classified as grown organic or non-organic. Code list: nl.cl015
List of alternative identifiers (\"AKA, also-know-as\") with which the asset is identified by third parties
trackTillage
booleanIndicates whether the cultivation, over the years, is done in fixed lanes with fixed tracks for machinery.\n\ntrue = track tillage is applied\nfalse = track tillage is not applied
useTitle
refCode to indicate the type of legal ownership of the field that is used for the crop. For eCrop in The Netherlands code list nl.cl412 is used for this
Indication of the year in which the cultivation is harvested.
#cropProtectionApplication
objectAll relevant crop protection application data as part of the PefCR calculation for one crop of one grower in one year
Properties
Details of the applied crop protection product
Total quantity of the applied crop protection products for a crop for a year by a grower
List of total quantities of the applied active substances of this product for a crop for a year by a grower
Total quantity of the applied active substance for a crop for a year by a grower
#cropProtectionSection
objectAll relevant crop protection data as part of the PefCR calculation for one crop of one grower in one year
Properties
List of applied crop protection products the footprint is based on.
#cropSection
objectAll relevant crop data as part of the PefCR calculation for one crop of one grower in one year
Properties
Additional questions about the crop for PefCR footprint calculation
Crop on which the footprint declaration is based.
#cultivationSection
objectAll relevant cultivation (materials) data as part of the PefCR calculation for one crop of one grower in one year
Properties
Additional questions about the used cultivation materials for PefCR footprint calculation
#dateTimeType
stringDatetime with RFC 9557 (prev. RFC 3339)/ISO-8601 standard (local) datetime format "YYYY-MM-DDThh:mm:ssZ" or "YYYY-MM-DDThh:mm:ss±hh:mm"
#dateType
stringDate with RFC 9557 (prev. RFC 3339)/ISO-8601 standard date format standard date format "YYYY-MM-DD" Format: date. Pattern: ^\d{4}-\d{2}-\d{2}$
#distributionSection
objectAll relevant distribution data as part of the PefCR calculation for one crop of one grower in one year
Properties
Additional questions about distribution for PefCR footprint calculation
#energyProductionAndConsumption
objectAll relevant the energy production and consumption data per type as part of the PefCR calculation for one crop of one grower in one year
Properties
Type of the produced and consumed energy. Codelist id cl902 (OpenAPI property name: 'type')
Total quantity of the type of produced and consumed energy for a crop for a year by a grower
#energySection
objectAll relevant energy production and consumption as part of the PefCR calculation for one crop of one grower in one year
Properties
Additional questions on energy production and consumption for PefCR footprint calculation
List of energy production and consumption per type the footprint is based on.
#equipmentAssignment
objectIdentifies a piece of equipment that is used in a certain operation, and the period and usage figures of that use.
Properties
The total distance covered by the equipment during the operation.
endDateTime
refThe date/timestamp the equipment stopped being used in the operation.
The equipment assigned to and used in the operation.
The total time the equipment was in use during the operation (e.g. working hours or engine hours).
The date/timestamp the equipment started being used in the operation.
#equipmentDetails
objectDetails of equipment used to support farming activities, such as tractors, implements, sensor systems, installations, or hand tools.
Properties
Type of equipment, for instance Tractor, ImplementAssembly, SensorSystem, Installation or HandTool. Code list: nl.agroconnect.codelist.cl962 (OpenAPI property name: 'type')
Name of the equipment
List of alternative identifiers (\"AKA, also-know-as\") with which the equipment is identified by third parties, e.g. GS1 GTIN, CGTB authorisation number, article code'
#fertilizerApplication
objectAll relevant synthetic fertilizer data as part of the PefCR calculation for one crop of one grower in one year
Properties
Type of the applied fertilizer product (OpenAPI property name: 'type')
nutrients
arrayList of total quantities of the applied nutrients of this product for a crop for a year by a grower
Total quantity of the applied nutrient for a crop for a year by a grower
Information of the applied fertilizer product
Total quantity of the applied fertilizer for a crop for a year by a grower
#fertilizerSection
objectAll relevant fertilizer data as part of the PefCR calculation for one crop of one grower in one year
Properties
Additional questions on fertilizer application for PefCR footprint calculation
List of (synthetic and organic) fertilizers the footprint is based on.
#footprintDeclaration
objectAll relevant data for PefCR calculation for one crop at one production location of one grower in one period
Properties
Identification of the footprint declaration as assigned by the data provider. (OpenAPI property name: 'id')
The grower who is owner of the crop the footprint is calculated on
Sequence number of the footprint declaration. Grower-identification, year and sequence number uniquely identify a footprint declaration (which can have multiple versions).
Start date of the period the footprint declaration applies to
Third party identifications of the footprint declaration.
Date-time of publication of the footprint declaration.
Version number of the footprint declaration. A footprint declaration, identified by grower, year and sequence number, can have multiple versions; the highest version number is the most recent.
#greenhouseLocationDetails
objectStructure with transparent walls and roof designed to regulate temperature and humidity for growing plants.
Properties
blockId
stringIdentifier of a block (in Dutch: afdeling) within the greenhouse.
hortivationpointBlock
stringCoordinates of the standard Hortivation location reference point for the block
Name of the greenhouse
postId
stringIdentifier of a post (in Dutch: paal) within the block of the greenhouse
List of alternative identifiers (\"AKA, also-know-as\") with which the greenhouse is identified by third parties
upToPostId
stringIdentifier of a second post (in Dutch: paal) within the block of the greenhouse. The upToPost can be used to refer to the location between two posts (postId and upToPostId).
waterTapId
stringIdentifier of a watertap (in Dutch: waterpunt) within a greenhouse.
The xyz-position to the standard Hortivationpoint of this block within a greenhouse
#grower
objectThe grower (e.g. the farmer) that is responsible for the cultivation of the crop.
Properties
emailAddress
stringE-mail address of the party
iban
stringInternational Bank Account Number (IBAN) of the party
Name of the party
personName
stringPersons name
phoneNumber
stringPhone number of the party
(OpenAPI property name: 'id')
telefaxNumber
stringTelefax number of the party
List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)
websiteUrl
stringAddress of the website of the party
#growerDetails
objectThe details of the grower (e.g. the farmer) that is responsible for the cultivation of the crop.
Properties
emailAddress
stringE-mail address of the party
iban
stringInternational Bank Account Number (IBAN) of the party
Name of the party
personName
stringPersons name
phoneNumber
stringPhone number of the party
telefaxNumber
stringTelefax number of the party
List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)
websiteUrl
stringAddress of the website of the party
#health
objectHealth Check Response Format for HTTP APIs
Properties
Indicates whether the service status is acceptable or not
knownValues: pass | warn | fail
#idType
objectGenerice IdType with which a resource is identified
#inboundDeliveryByGrower
objectMaterials and inputs delivered by a supplier to a grower as input for their crop process. An inbound delivery describes a certain amount of a certain product acquired by a grower through an order to a supplier.
Properties
Date at which the product is delivered at the location of the grower ("YYYY-MM-DD")
Identification of the production location of the grower at which the product is delivered
(OpenAPI property name: 'id')
Quantity of the product delivered to the grower.
List of alternative identifiers (\"AKA, also-know-as\") with which the inbound delivery is identified by third parties.
#inboundDeliveryBySupplier
objectMaterials and inputs delivered by a supplier to a grower as input for their crop process. An inbound delivery describes a certain amount of a certain product acquired by a grower through an order to a supplier.
Properties
Date at which the product is delivered at the location of the grower ("YYYY-MM-DD")
Identification of the production location of the grower at which the product is delivered
(OpenAPI property name: 'id')
Quantity of the product delivered to the grower.
List of alternative identifiers (\"AKA, also-know-as\") with which the inbound delivery is identified by third parties.
#inboundDeliveryDetails
objectDetails of materials and inputs delivered by a supplier to a grower as input for their crop process. An inbound delivery describes a certain amount of a certain product acquired by a grower through an order to a supplier.
Properties
Date at which the product is delivered at the location of the grower ("YYYY-MM-DD")
Identification of the production location of the grower at which the product is delivered
Quantity of the product delivered to the grower.
List of alternative identifiers (\"AKA, also-know-as\") with which the inbound delivery is identified by third parties.
#inboundDeliveryDetailsByGrower
objectDetails of the materials and inputs delivered by a supplier to a grower as input for their crop process. An inbound delivery describes a certain amount of a certain product acquired by a grower through an order to a supplier.
Properties
Date at which the product is delivered at the location of the grower ("YYYY-MM-DD")
Identification of the production location of the grower at which the product is delivered
Quantity of the product delivered to the grower.
List of alternative identifiers (\"AKA, also-know-as\") with which the inbound delivery is identified by third parties.
#inputAllocationDetails
objectOne or more inputs used to execute this operation. Examples of types of input are: crop protection products, fertilizer, water, energy, labor, etc.
Properties
Indicator for the type of input or output that is used or delivered by this operation. For instance: - "FERTIL" = fertilizer - "PROTEC" = crop protection product - "ENERG" = energy, etc. For this AgroConnect code list nl.agroconnect.codelist.cl271 is used. (OpenAPI property name: 'type')
characteristics
arraycomponents
arraySpecification of the mixed content (mixture of several components) of the input, for instance a fertilizer.
The greenhouse location the allocation applies to (optional).
name
stringShort name for this allocation.
plantSpecies
arrayThe plant species the allocation applies to, for instance the species that is planted or sown (optional).
Product used as allocation in this operation
Quantity of the allocation measured in absolute terms, meaning for instance applied liters or kilogram in total for this allocation (so not in liter/hectare of kilogram/hectare).
reason
stringShort description of the reason why this particular input (e.g. this crop protection product) is used.
List of alternative identifiers (\"AKA, also-know-as\") with which the allocation is identified by third parties.
#jsonPatch
arrayRequest payload for PATCH operations: a JSON Patch document as defined in ["JavaScript Object Notation (JSON) Patch", RFC 6902](https://datatracker.ietf.org/doc/html/rfc6902), per AASG rule P012. Use media type `application/json-patch+json`. The document is an array of operation objects, applied sequentially in the order given. If any operation fails, the whole patch document MUST NOT be applied (RFC 6902, section 5).
minLength: 1
Items
jsonPatch
array#jsonPatchOperation
objectOne RFC 6902 JSON Patch operation. 'value' is required for add, replace and test; 'from' is required for move and copy.
#link
objectA hyperlink based on RFC 8288 Web Linking, following the OGC API - Common Hyperlink Schema. Used consistently across both the OGC API Features resources and embedded business objects in this AASG.
Properties
The target URI of the link.
hreflang
stringA hint at the language of the link target.
mediaType
stringA hint at the media type of the link target. (OpenAPI property name: 'type')
The link relation type. Prefer values from the IANA Link Relations Registry; use the OGC Link Relation Registry or a custom AASG-defined URI for relation types not covered by IANA.
title
stringA human-readable label for the link target.
#links
objectA collection named "links"of RFC 8288 conformant links
#locationSection
objectAll relevant location data as part of the PefCR calculation for one crop of one grower in one year
Properties
Additional questions about the location for PefCR footprint calculation
Identification of the production location of the grower at which the crop is grown
#measureType
objectStandard data type for expressing a measurement with a value and unitcode. To be used for all types of measurements and quantities in this class model.
Properties
Expresses the measured value of the measurement. Integer mantissa, scaled by scaleFactor (originally a float).
Power of 10 exponent to apply to the integer value(s) of this object: realValue = value * 10^scaleFactor. E.g. value 125 with scaleFactor -2 is 1.25.
#nsidType
stringNamespace Identifier (NSID) Type used in the AT Protocol for decentralized identities, structured using reverse domain name syntax Pattern: ^[a-zA-Z]([a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?(\.[a-zA-Z0-9]([a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?)+(\.[a-zA-Z]([a-zA-Z0-9]{0,62})?)$
#nutrientDetails
objectDetails of an nutrient used in a fertilizer product.
Properties
List of additional nutrient characteristics
name
stringName of the nutrient
List of alternative identifiers (\"AKA, also-know-as\") with which the nutrient is identified by third parties
#operationDetails
objectActivity carried out by man and/or machine as part op the execution of a task. An operation performs a particular OperationTechnique on a particular asset (a crop,a field, a production unit, a batch, etc.) to realize a certain Cultural Practice or Husbandry Practice. Examples for CropProduction: The CulturalPractise "weed control"can be realized by one of various OperationTechniques like spraying, row cultivation, manual hoeing, etc.
Properties
area
refThe treated area (hectare, m2) during the execution of this operation. Can be a percentage of the total area or an absolute value (like hectare or square meter).
characteristics
arrayThe option to attach one or more characteristics about the execution of this operation.
endDateTime
refThe date/timestamp of the ending of execution the operation.
equipmentAssignments
arrayThe option to attach one or more pieces of equipment used to execute this operation.
inputAllocations
arrayThe option to attach one or more inputs used to execute this operation, such as crop protection products, fertilizer, water, energy, or labor.
Short name of the operation.
note
stringOptional free-text note about the operation.
The type of operation. Code list Id for arable farming: nl.agroconnect.cl127 (OpenAPI property name: 'type')
outputAllocations
arrayThe option to attach one or more outputs resulting from the execution of this operation, such as harvested produce or energy.
The date/timestamp of beginning the execution of the operation.
technique
refExamples for Crop Production: The CulturalPractise \"weed control\" can be realized by one of various OperationTechniques like spraying, row cultivation, manual hoeing, etc. \r\nCode list Id for arable farming: nl.cl127 (or nl.cl293)
List of alternative identifiers (\"AKA, also-know-as\") with which the operation is identified by third parties.
workerAssignments
arrayThe option to attach one or more workers assigned to execute this operation.
#outputAllocationDetails
objectOne or more outputs as the result of the execution of the operation. For example harvested produce: potatoes, onions, flowers, vegetables, etc. But an output could also be for instance energy.
Properties
Indicator for the type of input or output that is used or delivered by this operation. For instance: - "FERTIL" = fertilizer - "PROTEC" = crop protection product - "ENERG" = energy, etc. For this AgroConnect code list nl.agroconnect.codelist.cl271 is used. (OpenAPI property name: 'type')
characteristics
arrayThe greenhouse location the allocation applies to (optional).
name
stringShort name for this allocation.
plantSpecies
arrayThe plant species the allocation applies to, for instance the species that is planted or sown (optional).
Product used as allocation in this operation
Quantity of the allocation measured in absolute terms, meaning for instance applied liters or kilogram in total for this allocation (so not in liter/hectare of kilogram/hectare).
List of alternative identifiers (\"AKA, also-know-as\") with which the allocation is identified by third parties.
#partyDetails
objectData about the Party that is involved in producing or processing the crop and or agricultural produce.
Properties
emailAddress
stringE-mail address of the party
iban
stringInternational Bank Account Number (IBAN) of the party
Name of the party
personName
stringPersons name
phoneNumber
stringPhone number of the party
telefaxNumber
stringTelefax number of the party
List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)
websiteUrl
stringAddress of the website of the party
#plantSpecies
objectCrop type at the level of potato, sugar beet, onion, winter wheat, etc. For mixed crops more then one type of crop can be grown in the same period at the same plot.
Properties
percentageInMix
integerTo be used in case of a mixed crop. Indicator of the percentage of this crop species related to the other crop species that are part of this mixed crop. The percentage is based on the weight proportions of the seed of each of the species that are part of the mixed crop. Integer mantissa, scaled by scaleFactor (originally a float).
scaleFactor
integerPower of 10 exponent to apply to the integer value(s) of this object: realValue = value * 10^scaleFactor. E.g. value 125 with scaleFactor -2 is 1.25.
default: 0
Code of the plant species, at the aggregation level of potato, sugar beet, onion, etc. For eCrop in The Netherlands, code list nl.cl263 is used for crop species.
#plot
objectSurface (area) that is used to grow plants. The exact location of this surface is specified by either, a greenhouse-location a point location or a border location (using outer and inner polygons). The geo-information of a plot is published via the plot-geometry operations. A plot does not store the id of its feature(s): the link with rel `https://ecrop.agroconnect.nl/rel/plot-features` in the `links` of a Plot response is a query for the features that refer to this plot (a "backlink"), see GET /collections/plots/items.
Properties
alternativeName
stringOption to include a second, alternative, name for the plot. For instance to be used to include the name the farmer registered in his FMIS and the name that is registered in the RVO-database.
The surface (measured in for instance square meters, hectare) of this production plot.
characteristics
arraycountry
refThe country the plot is located in.
The land use category of this plot. Code list: nl.agroconnect.codelist.cl961. Possible values: ARL (Arable Land), GRL (Grassland), FLL (Fallow Land) and NTA (Natural Area).
Code for the soil type, as used for a specific use case. LocalSoilType code consists of the reference to the code list that is being used plus the code from this code list. For eCrop in arable farming in The Netherlands, code list nl.cl405 is used
(OpenAPI property name: 'id')
region
stringThe region the plot is located in.
Indicates whether this plot is classified for organic production or not. Production protocol: indicates whether this plot is classified for organic production or not. Code list: nl.cl015
Code for the soil type, as subscribed by a regulatory authority (e.g. MLNV-RVO in the Netherlands). For eCrop in The Netherlands code list nl.cl405 is used.
List of alternative identifiers (\"AKA, also-know-as\") with which the asset is identified by third parties
#plotDetails
objectDetails of the Surface (area) that is used to grow plants. The exact location of this surface is specified by either, a greenhouse-location a point location or a border location (using outer and inner polygons).
Properties
alternativeName
stringOption to include a second, alternative, name for the plot. For instance to be used to include the name the farmer registered in his FMIS and the name that is registered in the RVO-database.
The surface (measured in for instance square meters, hectare) of this production plot.
characteristics
arraycountry
refThe country the plot is located in.
The land use category of this plot. Code list: nl.agroconnect.codelist.cl961. Possible values: ARL (Arable Land), GRL (Grassland), FLL (Fallow Land) and NTA (Natural Area).
Code for the soil type, as used for a specific use case. LocalSoilType code consists of the reference to the code list that is being used plus the code from this code list. For eCrop in arable farming in The Netherlands, code list nl.cl405 is used
region
stringThe region the plot is located in.
Indicates whether this plot is classified for organic production or not. Production protocol: indicates whether this plot is classified for organic production or not. Code list: nl.cl015
Code for the soil type, as subscribed by a regulatory authority (e.g. MLNV-RVO in the Netherlands). For eCrop in The Netherlands code list nl.cl405 is used.
List of alternative identifiers (\"AKA, also-know-as\") with which the asset is identified by third parties
#plotType
stringThe type of production surface to grow plants. Can be a crop field for arable farming or a moving table (platform) for potted plants in floriculture.
knownValues: CROPFIELD | ACTIVITYFIELD | TABLE
#posInt32Type
integerminimum: 0
#posInt64Type
integerminimum: 0
#postalAddressType
objectSpecific ype for postal addresses
Properties
City name
country
refcountryName
stringCountry name
postalBoxId
stringPostal box number
postalCode
stringPostal code of the address
streetName
stringStreet name
streetNumber
stringStreet number
streetNumberExtension
stringExtension to the street number (e.g. an addition letter or suffix)
#primaryId
objectPrimary identification for the resources as assigned by the server
Properties
#primaryIdContentType
stringThe type for the content-part of primary ids of resources Format: uuid.
#primaryIdSchemeIdType
stringThe type for the schemeId part of primary ids of resources
#primaryIdType
objectPrimary identification for the resources as assigned by the server
Properties
#problemDetails
objectProblem details based on the ["Problem Details for HTTP APIs" specification, RFC 9457](https://datatracker.ietf.org/doc/html/rfc9457). Remark: According to Proposal NL API Design Rules 2.1 optional properties status, title and detail are required, type and instance are optional
Properties
A human-readable explanation specific to this occurrence of the problem.
errors
arrayList of individual validation errors, allowing multiple issues encountered while processing the request to be reported together in a single response (per AASG rule H007). This is an AASG-specific extension member of RFC 9457 Problem Details, not part of the base RFC itself.
instance
stringA URI reference that identifies the specific occurrence of the problem. It may or may not yield further information if dereferenced. Format: uri-reference.
problemType
stringA URI reference that identifies the problem type. Format: uri-reference. (OpenAPI property name: 'type')
The HTTP status code generated by the origin server for this occurrence of the problem.
minimum: 100maximum: 599
A short, human-readable summary of the problem type.
#processStateType
stringIndication of the execution status of the task or operation in terms of: proposed, planned, executed. Code list: nl.clL256
knownValues: PROPOSED | PLANNED | COMPLETED
#productDetails
objectDetails of a product delivered to a farmer, like any agricultural input, tool, or resource designed to support farming activities, such as seeds, fertilizers, animal feed or crop protection solutions.
Properties
List of additional product characteristics
name
stringName of the product
List of alternative identifiers (\"AKA, also-know-as\") with which the product is identified by third parties, e.g. GS1 GTIN, CGTB authorisation number, article code'
#productionLocation
objectThe the entity that is responsible for cultivation the crops.
Properties
emailAddress
stringE-mail address of the party
iban
stringInternational Bank Account Number (IBAN) of the party
Name of the party
personName
stringPersons name
phoneNumber
stringPhone number of the party
(OpenAPI property name: 'id')
telefaxNumber
stringTelefax number of the party
List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)
websiteUrl
stringAddress of the website of the party
#productionLocationDetails
objectThe details of the entity that is responsible for cultivation the crops.
Properties
emailAddress
stringE-mail address of the party
iban
stringInternational Bank Account Number (IBAN) of the party
Name of the party
personName
stringPersons name
phoneNumber
stringPhone number of the party
telefaxNumber
stringTelefax number of the party
List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)
websiteUrl
stringAddress of the website of the party
#productionSequenceType
stringIndicates if and how the crop is combined with other crops. Enumeration: PRE_CROP = voorteelt, MAIN_CROP = hoofdteelt, FOLLOWUP_CROP = volgteelt, MIXED_CROP = mengteelt
knownValues: PRE_CROP | MAIN_CROP | FOLLOWUP_CROP | MIXED_CROP
#substanceDetails
objectDetails of an active substance used in a crop protection product.
Properties
List of additional substance characteristics
name
stringName of the substance
List of alternative identifiers (\"AKA, also-know-as\") with which the substance is identified by third parties, e.g. CAS (Chemical Abstracts Service) number, EC (European Community) number '
#supplier
objectThe supplier who delivers goods to a grower
Properties
emailAddress
stringE-mail address of the party
iban
stringInternational Bank Account Number (IBAN) of the party
Name of the party
personName
stringPersons name
phoneNumber
stringPhone number of the party
(OpenAPI property name: 'id')
telefaxNumber
stringTelefax number of the party
List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)
websiteUrl
stringAddress of the website of the party
#supplierDetails
objectThe details of the supplier who delivers goods to a grower
Properties
emailAddress
stringE-mail address of the party
iban
stringInternational Bank Account Number (IBAN) of the party
Name of the party
personName
stringPersons name
phoneNumber
stringPhone number of the party
telefaxNumber
stringTelefax number of the party
List of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties (e.g. a gln, or chamber of commerce number)
websiteUrl
stringAddress of the website of the party
#task
objectA Task is the execution of one or more Operation's by a ma-machine-system. A 'task' consists of one ore more 'operations' that are closely related but involve different assents and resources. All combined operations need to be carried out well coordinated, to execute the task. For instance, the task potato harvesting involves: one tractor pulling the potato harvester, 2 units to take care of the transport of the harvested potatoes to the barn, equipment at the barn to unload the transport units and to bring the produce in the storing place.
Properties
endDateTime
refThe date/timestamp of the ending of execution the task.
Short name of the task.
note
stringOptional free-text note about the task.
(OpenAPI property name: 'id')
The date/timestamp of beginning the execution of the task.
List of alternative identifiers (\"AKA, also-know-as\") with which the task is identified by third parties.
#taskDetails
objectA Task is the execution of one or more Operation's by a ma-machine-system. A 'task' consists of one ore more 'operations' that are closely related but involve different assents and resources. All combined operations need to be carried out well coordinated, to execute the task. For instance, the task potato harvesting involves: one tractor pulling the potato harvester, 2 units to take care of the transport of the harvested potatoes to the barn, equipment at the barn to unload the transport units and to bring the produce in the storing place.
Properties
endDateTime
refThe date/timestamp of the ending of execution the task.
Short name of the task.
note
stringOptional free-text note about the task.
The date/timestamp of beginning the execution of the task.
List of alternative identifiers (\"AKA, also-know-as\") with which the task is identified by third parties.
#thirdPartyIdsType
arrayList of alternative identifiers (\"AKA, also-know-as\") with which the resource is identified by third parties
Items
thirdPartyIdsType
array#timeLocalType
stringTime with RFC 9557 (prev. RFC 3339) partial-time format "hh:mm:ss" Format: time-local. Pattern: ^(\d{2}):(\d{2}):(\d{2})$
#timeType
stringTime with RFC 9557 (prev. RFC 3339) full-time format "hh:mm:ss+/-hh:mm" Format: time. Pattern: ^(\d{2}):(\d{2}):(\d{2})(\.\d+)?(Z|[+-]\d{2}:\d{2})$
#treatmentZoneDetails
objectPart of the plot which is treated in an operation
Properties
area
refcharacteristics
arrayendLocation
stringSpecification of the end of the treatment zone. For instance an identifier of a bed of Tulips in an open field.
startLocation
stringSpecification of the beginning of the treatment zone. For instance an identifier of a bed of Tulips in an open field.
List of alternative identifiers (\"AKA, also-know-as\") with which the treatment zone is identified by third parties.
#visitorsAddressType
objectSpecific ype for visitor addresses
Properties
City name
country
refcountryName
stringCountry name
postalBoxId
stringPostal box number
postalCode
stringPostal code of the address
streetName
stringStreet name
streetNumber
stringStreet number
streetNumberExtension
stringExtension to the street number (e.g. an addition letter or suffix)
#wasteSection
objectAll relevant waste data as part of the PefCR calculation for one crop of one grower in one year
Properties
Additional questions about waste for PefCR footprint calculation
#waterConsumption
objectAll relevant the water consumption data per type as part of the PefCR calculation for one crop of one grower in one year
Properties
Total quantity of the type of water used for a crop for a year by a grower
Type of the applied water according to codelist nl.agroconnect.codelist.cl060 (OpenAPI property name: 'type')
#waterConsumptionSection
objectAll relevant water consumption data as part of the PefCR calculation for one crop of one grower in one year
Properties
Additional questions on water consumption for PefCR footprint calculation
List of water consumptions per type the footprint is based on.
#workerAssignment
objectIdentifies a worker that is assigned to a certain operation, and the period and execution time of that assignment.
Properties
endDateTime
refThe date/timestamp the worker stopped working on the operation.
The total time the worker spent executing the operation.
The date/timestamp the worker started working on the operation.
The worker assigned to the operation.
#workerDetails
objectDetails of a person that performs (part of) an operation, e.g. a farm employee or contractor.
Properties
E-mail address of the worker.
jobTitle
stringJob title of the worker.
Name of the worker.
phoneNumber
stringPhone number of the worker.
List of alternative identifiers (\"AKA, also-know-as\") with which the worker is identified by third parties, e.g. an employee number
#yearType
stringYear with RFC 9557 (prev. RFC 3339)/ISO-8601 standard date format "YYYY" Pattern: ^\d{4}$
Similar lexicons
semantic matchLexicons whose schemas describe something close to this one. Check them before publishing a new one that overlaps.
-
All relevant data for PefCR calculation for one crop at one production location of one grower in one period
-
nl.agroconnect.ecrop.plot
recordDetails of the Surface (area) that is used to grow plants. The exact location of this surface is specified by either, a greenhouse-location a point location or a border location (using outer and inner polygons).
-
nl.agroconnect.ecrop.crop
recordThe details of the cultivation of a specific crop type (e.g. potato, wheat, rice,. etc.) on one or more plots during a specific period of time, specified by startDateTime and endDateTime.
-
The details of the entity that is responsible for cultivation the crops.
-
nl.agroconnect.ecrop.grower
recordThe details of the grower (e.g. the farmer) that is responsible for the cultivation of the crop.